members.ironscales.com site service outage/slowdown

Incident Report for IRONSCALES

Resolved

This incident has been resolved.
Posted Nov 29, 2022 - 12:58 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 29, 2022 - 09:51 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 29, 2022 - 09:42 EST

Investigating

We are currently investigating US site members.ironscales.com slowdown and unavailability issue.
Posted Nov 29, 2022 - 09:35 EST
This incident affected: US Site (Dashboard, AppAPI, Office 365 Protection, Google Workspace Protection) and Phishing Simulation and Training.