Intermittent Disruptions in the US-hosted IRONSCALES environments

Incident Report for IRONSCALES

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 13:15 EST

Monitoring

We would like to inform you that the service disruption in our US-hosted data center has been fully resolved.
IRONSCALES has successfully processed the backlog of delayed emails, and no data loss has occurred.
All systems are now fully operational, and the issue is considered closed.
We appreciate your patience and support.

We are still closely monitoring the status of all systems.
Posted Feb 20, 2025 - 07:07 EST

Update

We are in the final stages of implementing the fix, and we can already observe significant improvements in the system's performance.
Posted Feb 20, 2025 - 04:34 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 19, 2025 - 20:47 EST

Update

We are continuing to work on the issue.
The technical team succeeded in narrowing down the problem and is now working closely with the AWS team and testing several possible solutions.
We will follow up with more updates soon.
Posted Feb 19, 2025 - 17:18 EST

Investigating

Dear customers, IRONSCALES has been experiencing intermittent issues in the US-hosted data center since morning GMT due to an unplanned database issue. This affects all customers that are hosted in our US data-center.
At the moment, there are no new incidents being created.
Your email flow is not interrupted, and all emails are arriving as usual.
We are in the process of fixing it with the highest priority.
Posted Feb 19, 2025 - 09:30 EST
This incident affected: US Site (Dashboard, AppAPI, Office 365 Protection, Google Workspace Protection, MS Teams Protection).