[US Site] Inspection and Mitigation Delays - Office 365 / Google Workspace
Incident Report for IRONSCALES
Resolved
This incident has been resolved.
Posted Mar 31, 2022 - 14:55 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 31, 2022 - 12:36 EDT
Monitoring
The US Site Microsoft Office 365 and Google Workspace are running behind, which is causing some delays in the emails' inspection and mitigation.
Posted Mar 31, 2022 - 12:03 EDT
This incident affected: US Site (Office 365 Protection, Google Workspace Protection).