The Investigation page in US-hosted IRONSCALES environments is now fully accessible. A partial data gap of approximately 2.5 hours has been identified during the disruption period. IRONSCALES is reviewing recovery options to determine if some of this data can be restored. All email protection services, including inspection and mitigation, remained fully operational and unaffected throughout the incident.
Posted Aug 28, 2025 - 12:02 EDT
Monitoring
IRONSCALES has resolved the issue that impacted the Investigation page in US-hosted environments, and full functionality has been restored. We are still monitoring
Posted Aug 28, 2025 - 12:01 EDT
Investigating
IRONSCALES is currently investigating an issue affecting the Investigation page in US-hosted environments. While the page remains accessible, some users may experience partial functionality or delays in content display. Our engineering team is actively working to identify the cause and will provide updates as more information becomes available.