Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 11, 2025 - 01:00 EDT
Scheduled
Due to an important software upgrade, the IRONSCALES EU site will be under maintenance on 11-May-2025.
Possible interference in the regular operation of dashboards and real-time protection is expected.
Posted May 08, 2025 - 08:23 EDT
This scheduled maintenance affected: EU Site (Dashboard, AppAPI, Office 365 Protection, Google Workspace Protection, MS Teams Protection) and Phishing Simulation and Training.