Access to simulation & training
Incident Report for IRONSCALES
Resolved
Problem resolved and simulation and training page is accessible now
Posted Aug 09, 2023 - 18:03 EDT
Investigating
We are aware of some customers experiencing an issue with accessing the phishing simulation & training page. There are no issues with the phishing simulation & training services, but rather an isolated incident related to accessing the corresponding webpage. Our team is diligently working on addressing this at the earliest and we'll update this status page with additional updates.
Posted Aug 09, 2023 - 16:04 EDT
This incident affected: Phishing Simulation and Training.