UAE region is experiencing issues due to AWS infrastructure downtime

Incident Report for IRONSCALES

Resolved

This incident has been resolved.
Posted Mar 01, 2026 - 14:44 EST

Monitoring

A fix to Dashboard access has been applied , our teams are monitoring the system and mitigating AWS infrastructure issue.
Posted Mar 01, 2026 - 10:48 EST

Update

Our engineers applied a workaround and recovered inspections and other functions, Dashboard access is still affected.
Posted Mar 01, 2026 - 09:44 EST

Investigating

We are currently investigating the issue and mitigation possibilities.
Posted Mar 01, 2026 - 08:29 EST
This incident affected: UAE Site (Dashboard, AppAPI, Office 365 Protection, Google Workspace Protection).