Dashboard is slow

Incident Report for IRONSCALES

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 13:15 EST

Monitoring

A fix was implemented, and the dashboard is fully functional now.
We are still closely monitoring the situation.
Posted Feb 20, 2025 - 04:30 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 19, 2025 - 20:48 EST

Update

We are continuing to investigate this issue.
Posted Feb 19, 2025 - 12:04 EST

Update

We are still looking into the issue.
Posted Feb 19, 2025 - 06:43 EST

Investigating

We are experiencing a degradation in our dashboard.
The team is investigating.
Posted Feb 18, 2025 - 15:19 EST
This incident affected: US Site (Dashboard, Office 365 Protection, Google Workspace Protection).